Author Topic: uTaser Code involved with debugging - how must it be?  (Read 173 times)

Offline Genisuvi

  • Newbie
  • *
  • Posts: 7
    • View Profile
uTaser Code involved with debugging - how must it be?
« on: March 04, 2019, 05:02:11 PM »
[img][img]I have an old project based on uTasker 1.3 running on MCF52258 uC. We have a legacy code warrior IDE (5.9.0) for coldfire arch. on W7 PC. After compiling we are unable to debug correctly using multilink programmer device (USB). After loading the file and running the application debug, debug seems to be hung after going to the start point. We can' t start the execution thread. Thread doesn' t stop at any breakpoints when application is doing things that means executing some instructions with active breakpoints. So we have the following messages when trying to go to step over, etc.. or next instruction: 1, 2, 3, 4 picture.

The sequence for debugging I have followed:

1)compile
2)make
3)Project/debug
4)run

There could be a lot of causes for this, but I would like to know if our uTasker code is well configurated for debugging and discart uTasker fault. How must be configured a project for debugging? Which uTasker files are involved? what are the variables or elements to be modified for debugging? Which values? I have seen a file called debug.c. Is there the code for debug configuration?

Thank you in advance.
« Last Edit: March 04, 2019, 05:04:28 PM by Genisuvi »

Offline mark

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2962
    • View Profile
    • uTasker
Re: uTaser Code involved with debugging - how must it be?
« Reply #1 on: March 06, 2019, 03:45:13 AM »
Hi

There is nothing special to be set in the project for debugging.
However, you may be having difficulties with the debugger if the watchdog is enabled - try disabling the watchdog and beware that the M5225x need a power cycle after disabling its setting before it will really disable it.

Regards

Mark

Offline Genisuvi

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: uTaser Code involved with debugging - how must it be?
« Reply #2 on: March 06, 2019, 09:13:01 AM »
Thank you Mark, I will try with this and I will report here the results.

Best regards.


Offline Genisuvi

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: uTaser Code involved with debugging - how must it be?
« Reply #3 on: March 07, 2019, 11:55:37 AM »
I could fix it. I try to explain here what was happening and the solution:

In one hand I was confused by the fact that we were compiling M5223x.c file for M52258 mcu. By other hand my error images was suggesting me some kind of connector problems. So I was affraid of missing some #define or flag, etc. But googling I found a post about users with the same problem and how fixed it on provider forum: dll problems with Testcfz unity of codewarriors after updating the multilink fw. I assumed that provider fixed it.
So, my suspicions  were focused on multilink device. I went to the PE page and look for current plugins, packages and driver updates. I installed the last package and we finally could debug perfectly!

I hope it could help to other people who face the same situation.

Regards.


« Last Edit: March 07, 2019, 11:57:26 AM by Genisuvi »