┬ÁTasker Forum

┬ÁTasker Forum => ┬ÁTasker general => Topic started by: kbluesky on November 28, 2012, 11:14:20 PM

Title: Simulator for MCF5223X with VS 2012
Post by: kbluesky on November 28, 2012, 11:14:20 PM
Hello, everybody or somebody;

I am quite new to the uTasker system for MCF5223X.  As usual, this is the problem of the simulator in a new environment. 

I have win7 professional 64bit system with VS 2012.  And I have uTaskerV1.4, the newest one.  I followed instructions to use .dsw file to make a proper version of the project, *.vcxproj for VS2012.  It was a smooth transition except the name of the project.  It only accept upto 'uTasker', so I should rename it to 'uTaskerV1-4'.  After that I can compile it (build it) in VS2012 environment; no error, no warning.  So I changed IP setup for our network and built it again.  Smooth and no hassles.  So, start to debug.  Set NIC and then see green light is blinking.  So I pinged to it from the command line.  Then "No reply".  Well, the funny thing is I can ping to it from other computer successfully.  I have checked with Wireshark.  It just behaved normally.  Whatever I tried, no use; changing mac address, Tx overflow setting, re-unzip and complie, etc.

I have read some related topics; dataoverflow issues, NIC setup, tcp hitting check, etc.  It just didn't reply at all in my own computer.  Still I can ping it even from our wireless network computer.  One time I debug this by setting the break point at tcp.c as Mark suggested.  After it hit that point, I proceed step by step till get some error; kernel32.dll & ntdll.dll are not found.  I have those in the proper directories, I guess.

Well, my computer has a Realtek chip for the network.  Should I use 'Microsoft Loopback Adapter' for this simulator?  I need this simulator first to check HTTP server function.  Any comments or questions please.....
Title: Re: Simulator for MCF5223X with VS 2012
Post by: mark on November 29, 2012, 01:30:12 PM

If you can ping the simulated device from another PC it looks as though it is essentially working correctly - the NIC to use is correct.

It may be that your PC is using checksum offloading - in such situations the MAC/IP of the simulated processor will show up in the PC's ARP table (ARP communication is OK) but IP communication fails due to the PC not sending any checksums to the NIC (if the IP checkum in the Wireshark recordings are all 0x0000 it is the case - this is not immediately obvious without specifically checking). This can be corrected as explained here (and its links):

Another potential problem is the firewall operation of your local PC. It is worth doing a quick check with the inbuilt firewall disabled to see whether it is then OK.

Trace messages in the simulator like "kernel32.dll & ntdll.dll are not found" can probably be ignored as long as it continues to operate. The VS resources are doing all sorts of checks when running and don't need to be able to find everything.



Title: Re: Simulator for MCF5223X with VS 2012
Post by: kbluesky on December 01, 2012, 01:10:30 AM
Hello, Mark;

Thank you for your reply.  Actually I have bypassed this problem.

The way to bypass is setting the Microsoft Loopback adapter.  With my old NIC, I cannot see any checksum offloading problem, nor firewall problem.  I can set ICMP free in the firewall.

Anyway, I installed the loopback adapter and set the proper IP for our network, no internet access.  Then it works immediately.  The Wireshark clearly shows the activity.

Title: Re: Simulator for MCF5223X with VS 2012
Post by: kbluesky on January 08, 2013, 02:24:50 AM

Just for the updating, because I don't want to spread the wrong answer for this issue. 

After I succeeded to build the project, I cold run the ping function.  That's it.  I couldn't run any other functions; ftp, telnet, etc.  I quit using win7 & VS2012.  Instead i moved to XP virtual machine and there I used VS 2008 and our company network.  It has worked beautifully; every function works just as expected.

Now I am using uTasker V1.4.011, the latest one, I guess and have tried to compile with GCC and also CW7.2.  The compliled w/ CW 7.2 works fine; I can load the webpages and deletes all to load the modified pages.

I hope others would not mislead from the previous answer.