Author Topic: Building AVR Studio 5 Project  (Read 11162 times)

Offline kmjackson

  • Newbie
  • *
  • Posts: 33
    • View Profile
Building AVR Studio 5 Project
« on: May 09, 2012, 07:55:38 AM »
Hi MArk,

I'm trying to build the Studio 5 uTasker project.  Unfortunately, I'm getting the following error.  I believe it can't find uTaskerBootLoader.o.  I simply downloaded, enter password and tried to build it.  The project is still using the makefile that came with the project.  Any Ideas?


------ Build started: Project: uTaskerV1.4, Configuration: uTaskerBoot AVR ------
Build started.
Project "uTaskerV1.4.cproj" (default targets):
Target "PreBuildEvent" skipped, due to false condition; ('$(PreBuildEvent)'!='') was evaluated as (''!='').
Target "CoreBuild" in file "C:\Program Files\Atmel\AVR Studio 5.1\Vs\Compiler.targets" from project "C:\Documents and Settings\kmjackson\Desktop\uTaskerV1.4_AVR32-5\uTaskerV1.4.cproj" (target "Build" depends on it):
   Using "RunCompilerTask" task from assembly "C:\Program Files\Atmel\AVR Studio 5.1\Vs\Compiler.Task.dll".
   Task "RunCompilerTask"
      C:\Program Files\Atmel\AVR Studio 5.1\make\make.exe -C "C:\Documents and Settings\kmjackson\Desktop\uTaskerV1.4_AVR32-5\Applications\uTaskerBoot\GNU_AVR32" -f "make_uTaskerV1.4_GNU_AVR32" all
      make: Entering directory `C:/Documents and Settings/kmjackson/Desktop/uTaskerV1.4_AVR32-5/Applications/uTaskerBoot/GNU_AVR32'
      avr32-gcc -march=ucr2 -mpart=uc3a0512 -Wall -Wstrict-prototypes -I../../uTaskerBoot -D _GNU -D _HW_AVR32 -g -c -Os ../uTaskerBootLoader.c -o Build/uTaskerBootLoader.o
      process_begin: CreateProcess(NULL, avr32-gcc -march=ucr2 -mpart=uc3a0512 -Wall -Wstrict-prototypes -I../../uTaskerBoot -D _GNU -D _HW_AVR32 -g -c -Os ../uTaskerBootLoader.c -o Build/uTaskerBootLoader.o, ...) failed.
      make (e=2): The system cannot find the file specified.
      make: *** [Build/uTaskerBootLoader.o] Error 2
      make: Leaving directory `C:/Documents and Settings/kmjackson/Desktop/uTaskerV1.4_AVR32-5/Applications/uTaskerBoot/GNU_AVR32'
   Done executing task "RunCompilerTask" -- FAILED.
Done building target "CoreBuild" in project "uTaskerV1.4.cproj" -- FAILED.
Done building project "uTaskerV1.4.cproj" -- FAILED.

========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

Offline mark

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3236
    • View Profile
    • uTasker
Re: Building AVR Studio 5 Project
« Reply #1 on: May 09, 2012, 02:12:19 PM »

One possibility is that the directory

\Applications\uTaskerBoot\GNU_AVR32\Build is missing or maybe it has been deleted.

The make file wants to put its object files there and if it doesn't exist it won't be able to.

However, when I try this I don't get exactly the same error message. However I can otherwise build the boot loader form AVR Studio 5 without any difficulties.

Check also that the file uTaskerBootLoader.c is indeed in \Applications\uTaskerBoot.

Finally, there may be some default paths in AVR Studio that are causing a problem. Try editing the make file to use absolte file path references to see whether you can solve one step, which would then indicate where the confusion lies. If you can prove that absolute paths are Ok you will need to search to see whether there are any path settings in AVR Studio that are causing it to work at a different location to the expected one.



Offline kmjackson

  • Newbie
  • *
  • Posts: 33
    • View Profile
Re: Building AVR Studio 5 Project
« Reply #2 on: May 09, 2012, 10:39:21 PM »
Ok, problem fixed.  I'm using Studio 5.1 and I needed to change the paths for make.exe and the AVRToolchain as followed:

SET PATH=%PATH%;C:/Program Files/Atmel/AVR Studio 5.1/extensions/Atmel/AVRGCC/
SET PATH=%PATH%;../../../tools
SET PATH=%PATH%;C:/Program Files\Atmel/AVR Studio 5.1/make
make -f make_uTaskerV1.4_GNU_AVR32 all