Author Topic: IAR EWARM v9 Support  (Read 238 times)

Offline BrandonT

  • Newbie
  • *
  • Posts: 3
    • View Profile
IAR EWARM v9 Support
« on: July 21, 2021, 07:59:39 AM »
What is the latest version of IAR EWARM against which the pre-configured projects have been qualified? I am currently using IAR EWARM 9.10.

Offline mark

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3158
    • View Profile
    • uTasker
Re: IAR EWARM v9 Support
« Reply #1 on: July 21, 2021, 02:37:19 PM »
Hi

I have been using 8.50.9.
From experience the exact version shouldn't make any noticeable difference - no code changes have been made for IAR since initial IAR 4 compatibility and the new IAR versions generally are due to changes in he IDE itself (editor, debugger) and the additional of more processor types that it supports.
In addition since the move form IAR4 to IAR5 (which lost compatibility with the IDE projects) subsequent generations have always been backward compatible.

Regards

Mark

Offline BrandonT

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: IAR EWARM v9 Support
« Reply #2 on: July 22, 2021, 01:25:13 PM »
I can confirm that IAR EWARM 9.10 does indeed work as expected.

I did, however, find that the IAR EWARM flashloader balked when attempting to flash my binary to the K60. I was able to determine that the flashloader was failing to handle the f_config section.

In order to allow the flashloader to write flash configuration, I had to modify the existing board file it used. I had to add the --enable_config_write parameter as indicated in the attached file: