Author Topic: Can't build simulator app  (Read 3670 times)

Offline NedK

  • Newbie
  • *
  • Posts: 3
    • View Profile
Can't build simulator app
« on: May 03, 2022, 06:27:16 PM »
I'm trying to build the i.mxRT simulator application (in Windows 10 64-bit) under Microsoft Visual Studio Community 2022 (64-bit), Version 17.1.6.
I'm building from the V2.0.0 branch, based on commit e0e0bc9c7e3dc28d0f035bf7aacea3d2e3955ed2.
I've read the "getting started" PDF.
I can build the target application successfully using the make_uTaskerV1.4_GNU_iMX makefile.
However, when I go to build the Windows solution (using either the uTasker i.MX or uTasker i.MX plus GNU build targets), the compile fails upon trying to build FreeRTOS objects:

Build started...
1>------ Build started: Project: uTaskerProject, Configuration: uTasker i.MX Win32 ------
1>Z:\uTasker-GIT-Kinetis\FreeRTOS\Source\include\FreeRTOS.h(33,10): fatal error C1083: Cannot open include file: 'stddef.h': No such file or directory
1>Z:\uTasker-GIT-Kinetis\FreeRTOS\Source\stream_buffer.c(29,10): fatal error C1083: Cannot open include file: 'string.h': No such file or directory
1>Generating Code...
1>Done building project "uTaskerV1-4.vcxproj" -- FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I'm not familiar with Visual Studio, so maybe it's something I'm doing wrong.
I've tried both the .sln and the .vcxprog solution/project files with the same result.

Offline mark

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3237
    • View Profile
    • uTasker
Re: Can't build simulator app
« Reply #1 on: May 03, 2022, 08:50:43 PM »

Those two headers are supplied by the compiler library which is presumably either missing can't be found.
It may be something with VS 2022 (I am still using VS 2019) or it may be something missing during its installation - potentially you haven't installed an option that is required since, if i remember correctly, VS 2019 installs the IDE but not all of the language packages and it may be that you need to tell it that you need its C/C++ package which will then deliver the missing libraries.

As a reference I find these two missing files in the folder
C:\Program Files (x86)\Windows Kits\10\Include\10.0.19041.0\ucrt

I believe VS 2022 is being used by some and I didn't hear of such issues and therefore I am tending to think that it will be an installation option problem - check out this Microsoft page and verify that the "Desktop development with C++" workload is included.

Good luck



Offline NedK

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Can't build simulator app
« Reply #2 on: May 04, 2022, 03:36:38 PM »
Thanks, adding several SDKs using the Visual Studio Installer made it compile correctly.