Author Topic: Visual Studio and NIC settings  (Read 3310 times)

Offline FAQ

  • Newbie
  • *
  • Posts: 26
    • View Profile
Visual Studio and NIC settings
« on: March 20, 2009, 03:41:49 PM »
I'm using visual studio 2008 and I don't find how to Ensure that the compiler is set up for the M5223X target in the project’s pre-compiler
settings. also I don't know how simulate the nic.

Offline mark

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3162
    • View Profile
    • uTasker
Re: Visual Studio and NIC settings
« Reply #1 on: March 20, 2009, 03:44:48 PM »
Hi

1)   In VS2008 verify:
- Menu Build | Configuration Manager… now set the configuration to the build that you want (there is generally one for the target eg. M5223X and one for the target + GNU post built)
- In the solution explorer (left hand side) click on the project “uTasker”. Right mouse click and open “Properties”. Expand Configuration Properties -> C/C++ and then “Pre-processor”. Here you can see the pre-processor settings. _M5223X should be set if using the Coldfire, or others as noted in the particular tutorial.
2)   When you run the simulator you will see the chip and some menus. Open the menu “LAN | Select working NIC”. Then open the drop-down list to see the NICs available on your PC. Select the network card which is to be used and click OK. Close the simulator (File | Exit) to save this setting. The NIC setting only has to be saved once and then is used automatically each time the simulator is re-started.

Regards

Mark
« Last Edit: March 22, 2009, 05:47:09 PM by mark »